SubMain - CodeIt.Right The First Time!

/Community

Support Community for SubMain Products
 Home Products Services Download Purchase Support
in Search
 
Home Forums Blogs Tutorials/CIR Tutorials/GD Downloads
Welcome to SubMain Community Sign in | Join | Help

Stop enum values being prefixed with 'The'

Last post 04-27-2017, 8:02 AM by Misha Zhutov (SubMain). 1 replies.
Sort Posts: Previous Next
  •  04-27-2017, 4:33 AM 4950

    Stop enum values being prefixed with 'The'

    Is there a way to stop enum value XML comments automatically being prefixed with 'The'? e.g. to just have

      /// <summary>
    /// Organisation
    /// </summary>
    Organisation = 2, 

    rather than

    /// <summary>
    /// The organisation
    /// </summary>
    Organisation = 2, 

     

  •  04-27-2017, 8:02 AM 4952 in reply to 4950

    Re: Stop enum values being prefixed with &#39;The&#39;

    Attachment: FieldRule.png

    Hello,

    You can open Tools->GhostDoc->Options->Rules->Fields->Default Documentation and change summary macro from

    $(FieldName.Words.TheAndAllAsSentence)$(End)

    to

    $(FieldName.Words.AllAsSentence)$(End) - please take a look at attached screenshot. 

     



    Thank you,
    Misha Zhutov
    http://submain.com - .NET Developer Tools | Microsoft VB MVP
View as RSS news feed in XML
 
     
 
Home |  Products |  Services |  Download |  Purchase |  Support |  Community |  About Us |