SubMain - CodeIt.Right The First Time!

/Community

Support Community for SubMain Products
 Home Products Services Download Purchase Support
in Search
 
Home Forums Blogs Tutorials/CIR Tutorials/GD Downloads
Welcome to SubMain Community Sign in | Join | Help

Remarks or other changes not showing up in the Preview

Last post 07-12-2017, 1:30 AM by Misha Zhutov (SubMain). 3 replies.
Sort Posts: Previous Next
  •  07-08-2017, 8:01 AM 5000

    Remarks or other changes not showing up in the Preview

    I am new and trying the trail version, but can not seem to have the changes I make appear in the preview.  Can someone help?

    I generated the documentation for a method, then went in and edited some of the text.  Below is the code:

     

        ''' <summary>

        ''' Synchronizes from pick.

        ''' </summary>

        ''' <remarks> Rebuilds the ShSrce and ShLotC tables (and ShipmentDetail table if Shipment) from the shippick table.

        ''' These tables will be rewritten each time based upon the records in ShipPick.  This will be called after 

        ''' returning from the Picking Dialog.  This will not create any ShipmentContainers as the picking dialog 

        ''' will only be initiated from one Container on the Shipment.  May want to have it </remarks>

        ''' <param name="iCn">The SQL connection.</param>

        ''' <param name="iAppDb">The i application database.</param>

        ''' <param name="iShipNo">The i ship no.</param>

        ''' <param name="iShipLine">The i ship line.</param>

        ''' <param name="iFacility">The i facility.</param>

        ''' <param name="iLog">The i log.</param>

        ''' <returns><c>true</c> if XXXX, <c>false</c> otherwise.</returns>

        ''' <exception cref="System.Exception">

        ''' Variable curLocType: '" & curLocType & "' is Invalid

        ''' or

        ''' Variable curLocType: '" & curLocType & "' is Invalid

        ''' </exception>

    So I added the remarks and changed the text of <param name="iCn">The SQL connection.</param>.  these are not showing when i do the preview.  What is wrong??

  •  07-09-2017, 1:04 AM 5001 in reply to 5000

    Re: Remarks or other changes not showing up in the Preview

    Hello,

    Did you run "Preview Comment"? What GhostDoc version are you using? Please provide us with method declaration.

     


    Thank you,
    Misha Zhutov
    http://submain.com - .NET Developer Tools | Microsoft VB MVP
  •  07-11-2017, 12:20 PM 5003 in reply to 5001

    Re: Remarks or other changes not showing up in the Preview

    Yes I ran the preview comment. and I am on the latest trial (Pro).
  •  07-12-2017, 1:30 AM 5004 in reply to 5003

    Re: Remarks or other changes not showing up in the Preview

    Attachment: CommentPreview.png

    After updating XML documentation please click Refresh button on Comment Preview toolwindow (attached screenshot). The difference with Synchronize is that Refresh re-builds the preview. Synchronize button is used cached comments when navigating between different code elements.



    Thank you,
    Misha Zhutov
    http://submain.com - .NET Developer Tools | Microsoft VB MVP
View as RSS news feed in XML
 
     
 
Home |  Products |  Services |  Download |  Purchase |  Support |  Community |  About Us |