SubMain - CodeIt.Right The First Time!

/Community

Support Community for SubMain Products
 Home Products Services Download Purchase Support
in Search
 
Home Forums Blogs Tutorials/CIR Tutorials/GD Downloads
Welcome to SubMain Community Sign in | Join | Help

Tests ended up "Not Included" - How do they get there?

Last post 11-19-2012, 10:47 PM by Misha Zhutov (SubMain). 3 replies.
Sort Posts: Previous Next
  •  01-23-2012, 9:54 AM 1960

    Tests ended up "Not Included" - How do they get there?

    Environment: Visual Studio 2008. TestMatrix v. 3.1 (latest build) 

    I recently moved a large solution (multiple projects, 500+ unit tests) from one PC to another.

    I've used TestMatrix constantly on the original PC. No problems. But when I installed TestMatrix on the new PC (licensed with a fresh key we purchased right then) , all of the unit tests end up in a "Not Included" category when I look at them in the Test Explorer. They don't run, of course, when I fire up TestMatrix.

    What can do I to fix this?

    How did those tests end up in this category?

    Thanks for the attention,

    Pete 

    Filed under:
  •  02-17-2012, 11:01 PM 1976 in reply to 1960

    Re: Tests ended up "Not Included" - How do they get there?

    Hi Pete,

    Could you please send us TestMatrix log files for troubleshooting? You will find them in <My Documents>\SubMain\TestMatrix\

    What version of the .NET Framework your projects are targeting and what platform (x86 or AnyCPU)?  

    What version of NUnit framework do you use?

    Thanks!


    Thank you,
    Serge Baranovsky
    http://submain.com - .NET Developer Tools  |  Microsoft MVP  |  ASP Insider
    » » CodeIt.Right Will Fix Your Code!™ - http://submain.com/codeit.right
    » » C#/VB .NET Coding Guidelines - FREE 100+ page ebook (PDF) http://submain.com/guidelines
  •  11-19-2012, 1:10 PM 2952 in reply to 1976

    Re: Tests ended up "Not Included" - How do they get there?

    Sorry for the late, late reply to this post. I went back to my old machine and forgot about the whole mess. I recently got a new machine and am having the exact same problem.

    VS2008 

    .NET framework 3.5 sp1.

    Target platform x86.

    NUnit framework is version 2.5.9.10348 

     

    Where would you like me to send the logs? 

  •  11-19-2012, 10:47 PM 2953 in reply to 2952

    Re: Tests ended up "Not Included" - How do they get there?


    Hi Pete,

    Please send us LOG files to support@submain.com


    Thank you,
    Misha Zhutov
    http://submain.com - .NET Developer Tools | Microsoft VB MVP
View as RSS news feed in XML
 
     
 
Home |  Products |  Services |  Download |  Purchase |  Support |  Community |  About Us |