We Moved - This Forum is now Read-Only

Our new community is now available at https://support.submain.com/community/. We will leave historical discussions here in this forum view-only mode for search purposes, but moving forward, please post your questions in the appropriate category in the new community.

 
  SubMain - CodeIt.Right The First Time!

/Community

Support Community for SubMain Products
 Home Products Services Download Purchase Support
Search
 
Home Forums Blogs Tutorials/CIR Tutorials/GD Downloads
Welcome to SubMain Community Sign in | Join | Help

Multiple redundant attribute decorators appear in the built help file

  •  01-07-2015, 1:45 PM

    Multiple redundant attribute decorators appear in the built help file

    When I build my help web pages, I get quite a few pages that have this problem in the syntax section:
     

    Syntax



     The DataMemberAttribute tag appears 4 times for no reason.  My code looks like this:
     
        ''' <summary> ''' Input and output parameter wrapper for the <see cref="Assessment.GetAssessment">GetAssessment()</see> method. ''' </summary> ''' <tags>Web Services</tags> <DataContract()> _ Public Class AssessmentDataContract Inherits DataContracts.BaseServiceDataContract ' (...) ''' <summary> ''' String. Agency-configured case identifier. ''' </summary> ''' <tags>Web Services</tags> <DataMember()> Public Property CaseNumber As String 
    ' (...)
        End Class
    

View Complete Thread
 
     
 
Home |  Products |  Services |  Download |  Purchase |  Support |  Community |  About Us |