We Moved - This Forum is now Read-Only

Our new community is now available at https://support.submain.com/community/. We will leave historical discussions here in this forum view-only mode for search purposes, but moving forward, please post your questions in the appropriate category in the new community.

 
  SubMain - CodeIt.Right The First Time!

/Community

Support Community for SubMain Products
 Home Products Services Download Purchase Support
in Search
 
Home Forums Blogs Tutorials/CIR Tutorials/GD Downloads
Welcome to SubMain Community Sign in | Join | Help

VS 2017 Versioning problem

Last post 06-16-2017, 11:13 AM by Serge B. (SubMain). 3 replies.
Sort Posts: Previous Next
  •  05-31-2017, 7:13 AM 4987

    VS 2017 Versioning problem

    When I download GhostDoc Pro from your site and install it, it installs version 5.5.17070. Everytime I run VS 2017 now I get a notification that 1.0 is available.

    If Install that VISX, next run I will still get the SAME notification that version 1.0 is available and it shows 5.5.17070 in the about menu.

    This doesn't just happen to my machine, it happens on the entire team's machines.

  •  05-31-2017, 10:39 AM 4988 in reply to 4987

    Re: VS 2017 Versioning problem

    Hello,

    This is a result of moving to VSIX deployment for VS2017 - the VSIX installer is quite limited to be able to detect the previous MSI-based version installed.

    In most cases, this is solved by uninstalling the older version in Programs and Features.

    Please see these KB articles for more details:

    If this does not solve the issues you are experiencing, please email us at support at submain dot com and we will work with you to get this resolved.

    Thanks! 

     


    Thank you,
    Serge Baranovsky
    http://submain.com - .NET Developer Tools  |  Microsoft MVP  |  ASP Insider
    » » CodeIt.Right Will Fix Your Code!™ - http://submain.com/codeit.right
    » » C#/VB .NET Coding Guidelines - FREE 100+ page ebook (PDF) http://submain.com/guidelines
  •  06-16-2017, 10:32 AM 4991 in reply to 4988

    Re: VS 2017 Versioning problem

    OK - so I've tried what you suggest and it does work but ... The problem now is that GhostDoc is NOT available in VS 2015 or VS 2013 and yes, I need and use all three version and yes, I have GhostDocPro license. When I install the EXE or the MSI for 2015 and 2013 I get the versioning problem again in VS2017.

     Thoughts?

     

  •  06-16-2017, 11:13 AM 4992 in reply to 4991

    Re: VS 2017 Versioning problem

    Yes, you need to install run the EXE setup for VS2103-VS2015, it won't mess up your VS2017 setup, just make sure you do not have the VS2017 checked while installing the EXE. 

    Please see for more details: 

    Thanks!

     


    Thank you,
    Serge Baranovsky
    http://submain.com - .NET Developer Tools  |  Microsoft MVP  |  ASP Insider
    » » CodeIt.Right Will Fix Your Code!™ - http://submain.com/codeit.right
    » » C#/VB .NET Coding Guidelines - FREE 100+ page ebook (PDF) http://submain.com/guidelines
View as RSS news feed in XML
 
     
 
Home |  Products |  Services |  Download |  Purchase |  Support |  Community |  About Us |